Vintage Dirt Bike Q & A

Anything and everything about Vintage Dirt Bikes! After you Register, email nathan@alp-sys.com and let me know so I can activate you.
It is currently Sat May 26, 2018 12:19 am

All times are UTC - 7 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Mar 15, 2009 2:31 pm 
Offline

Joined: Sun Jan 23, 2005 6:03 pm
Posts: 1
I've got an F7 175 with a new top end, new piston, good compression (140 psi). Here's my dilemma...

According to the service manual, the rotary valve is timed correctly. There is a dimple on the valve that lines up with the woodruff key, but whenever I try to crank the bike, I can see air/fuel spitting out of the carb, and it doesn't feel like it is drawing air into the carb ever. Probably goes without saying that the bike doesn't run. This thing has been kicking my butt off/on for around 5 years now! The ignition timing is perfect, there are no end seal leaks, crank seal leaks, anything...I just can't get the whole rotor timing thing figured out.


Anyone got any ideas?

Thanks!

Sean


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group