Vintage Dirt Bike Q & A

Anything and everything about Vintage Dirt Bikes! After you Register, email nathan@alp-sys.com and let me know so I can activate you.
It is currently Sat Sep 22, 2018 11:26 pm

All times are UTC - 7 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed May 05, 2010 3:41 pm 
Offline

Joined: Tue May 04, 2010 3:26 pm
Posts: 1
Hey guys, I have a 1979 KX125 that I got for my son. The bike was a bit in a shambles when I got it. I had to extend the spark plug cable to reach the spark plug, I needed to put the piston and jug back on the bike and do some cosmetic touch ups to the bike. So....here is the deal. I get the bike running, idles great and putts around fine....shifts in all gears but when you try to get it on the pipe, it falls flat on it's face. It just totally looses all go. So, we tried to adjust the clip on the needle. No good, tried to switch jets, no good. Got to looking at the jets, they were frankenstiened. Ordered new jets from Mukuni......no good. Set the timing....no good. Tried to retart and advance the timing by super small incroments....no good. Blew out the pipe and muffler. No good. Ran this thing with and without the air cleaner...no good. Ran it with no pipe, ran it with just the expansion chamber and full exaust.....no good. WTF?????? I cannot figure out this thing. It seems like you can get it up and running and just as it's about to wrap out and hit that pipe, it bougs down. You can back off the throttle just a touch, and it want's to clean up, and sometimes it does, but not like it should. Has anyone come accross this before, if so what is the cure. It's driving me nuts!!!!!!!!!!!!!!!! Thanks for your help. Matt


Top
 Profile  
 
PostPosted: Sun Dec 05, 2010 8:29 pm 
Offline

Joined: Wed Sep 29, 2010 6:57 am
Posts: 64
Have you done a crankcase bleed-down test? I have had them lose power like that when the crank seals are shot...you can test it and get good compression on the top-end but lose it all out the bottom thru the crank seals....D


Top
 Profile  
 
PostPosted: Fri May 11, 2012 11:46 am 
Offline

Joined: Mon Apr 02, 2012 2:58 pm
Posts: 51
Have you checked the stator and CDI? Is the coil grounded well? Crankcase seals/bearings done? Air leak at the intake?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group